15 Aug 2016 #1

Randomly not saving templates

Regular user
Issue from 1.1 is still there - sometimes (rarely) you have to press F5 to reload the page and apply the changes again. Save is not working. Anyway it occurs less then before
  • 1
  • 2
Shade 15 Aug 2016 Edited
#2
Thank you for your report Eldenroot, indeed the bug is still there. I am testing 1.4 and so far so good, but still needs a bit of tweaking. Can you confirm that the issue just happens when editing templates?
Eldenroot 15 Aug 2016
#3
As I said - it is really rare but it happens. Difficult to reproduce properly, I detected this bug only in templates so far
Shade 15 Aug 2016
#4
Thank you, added to FASTyle development.
Shade 15 Aug 2016
#5
I have uploaded a beta version of FASTyle 1.4 to FASTyle development. Feel free to install and try it. Should solve this issue once for all, but still needs testing.
Brenda 19 Feb 2017
#6
Unfortunately this is still happening way too often.
Shade 24 Feb 2017
#7
That's true, and I have no clues left to solve the issue once for all.
Shade 21 Mar 2017
#8
I could isolate the issue with some luck. Apparently the hidden input pointing to the template identifier changes randomly under certain conditions and gets reset to the "default" templates tid. So:
  1. The template you are currently editing it not updated;
  2. The global template copy is not updated, since MyBB does not allow this operation by design.

The solution, regardless of when and where that input changes, is simple yet effective: attach the tid directly to FASTyle JS instead of fetching inputs every time you save.

This will solve the issue definitely.
Brenda likes this post
Brenda 21 Mar 2017
#9
Really nice to hear u could find the issue.

The best mybb plugin imo. :) I suppose we can expect an update soon then?
Shade 21 Mar 2017
#10
Very soon.