Click anywhere to close this dialog

Farewell

Great is the art of beginning, but greater is the art of ending
Henry Wadsworth Longfellow

I announce that I cease all development and activity in the programming universe indefinitely. My career has reached the turning point I was not expecting for at least another year, leaving me highly off guard and without laid-out plans for this hobby's continuity. I have begun a 5-year residency program in Neurosurgery which is clearly not compatible, time-wise, with programming.

I gave in all my passion for developing, and you gave me back your loyalty and trust, even when I did not deserve that much. Now it is the time for payback. I release all my present and past work as Open Source software, in the hope some talented developer will continue maintaining and expanding my vision of a modern, sleek forum software. The intrinsic flexibility of MyBB is the true hidden gem of an otherwise outdated codebase; I do hope the project can continue and be updated complying to the latest coding standards.

I hereby thank Euan, kawaii, andrewjs18, Ben, Matt, Omar G., effone, Eric J., Devilshakerz, Wildcard, JordanMussi and all the other team members I have had the opportunity to work with when I was a MyBB team member. I thank Tomm M, my mentor, who inspired me to pick up coding with his piece-of-art plugins. And finally, I thank all of you MyBBoost subscribers who have helped me getting through my toughest university years economically.

Yours sincerely, Filippo

Works only in webkit based browsers

18 Sep 2019
#1
This issue is marked as solved
For firefox and others, there's an error

`TypeError: b is null`

Try opening mybboost.com in firefox for example and hover someone's username.
Shade 18 Sep 2019 Edited
#2
That's weird, I usually test it in the three major browser engines (Webkit, Mozilla, Opera). I'll have a look later.

Tested in latest Firefox, works for me. Which browser are you using exactly?
ProX 18 Sep 2019 Edited
#3
FF Quantum 69.0 (64-bit)

No addons/default browser settings in private window
[Image: image-419.png]
Shade 20 Sep 2019
#4
Odd enough, with the same version on a Mac it works. The faulty code is Color Thief, a library used to calculate the dominant color of the avatar. Can you confirm that disabling the automatic code detection option Hovercards works in FF?
Shade 20 Sep 2019
#5
Btw, Color Thief has received an update, so I might update Hovercards. Can you please reach me out on Discord so we can test on Windows? I just have a Mac. Thanks! [email protected]
Shade 27 Sep 2019
#6
Bump.
ProX 27 Sep 2019
#7
Yes, it works when adaptive color is disabled. I'm not using discord and not very often around as job has taken my time nowadays. Should be better to try with someone else to test it
Shade 27 Sep 2019
#8
No problem, I understand. Thanks for confirming.