Unknown error from FacebookRedirectLoginHelper

26 Nov 2016 Edited
#1
Today, 12:45 PM Code : 0 /home/ehh/www/forums/myfbconnect/src/Facebook/Helpers/FacebookRedirectLoginHelper.php

Line : 244
Shade 26 Nov 2016
#2
This is not informative at all. You must download the report and post it here, not copy & paste the line generated in the report centre.
AlexanderPep 26 Nov 2016 Edited
#3
report myfacebook - .xml


Quote<?xml version="1.0" encoding="UTF-8"?>
<report name="MyFacebook Connect" version="3.1">
<id>1</id>
<dateline>1480153540</dateline>
<code>0</code>
<file>/home/ehh/www/forums/myfbconnect/src/Facebook/Helpers/FacebookRedirectLoginHelper.php</file>
<line>244</line>
<message>Cross-site request forgery validation failed. Required param "state" missing from persistent data.</message>
<trace> /home/ehh/www/forums/myfbconnect/src/Facebook/Helpers/FacebookRedirectLoginHelper.php(221): Facebook\Helpers\FacebookRedirectLoginHelper->validateCsrf()
#1 /home/ehh/www/forums/inc/plugins/MyFacebookConnect/class_facebook.php(127): Facebook\Helpers\FacebookRedirectLoginHelper->getAccessToken()
#2 /home/ehh/www/forums/myfbconnect.php(65): MyFacebook->save_token()
#3 {main}</trace>
</report>
Shade 27 Nov 2016
#4
Thank you, I will investigate.

By the way, use the built-in attachment manager next time. There's no need to use an external file uploader.
AlexanderPep 30 Nov 2016 Edited
#5
Any solution?
Shade 30 Nov 2016
#6
I am currently not available due to uni commitments, sorry.
thir13en 12 Apr 2017
#7
Hello,
I am having the exact same issue with the latest plugin version (3.1).
Any ideas?
nixer55 23 Jul Edited
#8
Seeing this error code 0 in my bug reports as well. Along with code 200:

<?xml version="1.0" encoding="UTF-8"?>
<report name="MyFacebook Connect" version="3.5">
        <id>694</id>
        <dateline>1595278558</dateline>
        <code>200</code>
        <file>/home/dartsnut/domains/dartsnutz.net/public_html/forum/myfbconnect/src/Facebook/Exceptions/FacebookResponseException.php</file>
        <line>137</line>
        <message>(Blank Page on login link) Missing Permissions</message>
        <trace> /home/dartsnut/domains/dartsnutz.net/public_html/forum/myfbconnect/src/Facebook/FacebookResponse.php(210): Facebook\Exceptions\FacebookResponseException::create(Object(Facebook\FacebookResponse))
#1 /home/dartsnut/domains/dartsnutz.net/public_html/forum/myfbconnect/src/Facebook/FacebookResponse.php(255): Facebook\FacebookResponse->makeException()
#2 /home/dartsnut/domains/dartsnutz.net/public_html/forum/myfbconnect/src/Facebook/FacebookResponse.php(82): Facebook\FacebookResponse->decodeBody()
#3 /home/dartsnut/domains/dartsnutz.net/public_html/forum/myfbconnect/src/Facebook/FacebookClient.php(224): Facebook\FacebookResponse->__construct(Object(Facebook\FacebookRequest), '{"error":{"mess...', 403, Array)
#4 /home/dartsnut/domains/dartsnutz.net/public_html/forum/myfbconnect/src/Facebook/Facebook.php(469): Facebook\FacebookClient->sendRequest(Object(Facebook\FacebookRequest))
Flyover 2.4 /home/dartsnut/domains/dartsnutz.net/public_html/forum/myfbconnect/src/Facebook/Facebook.php(336): Facebook\Facebook->sendRequest('GET', '/me?fields=id,n...', Array, Object(Facebook\Authentication\AccessToken), NULL, 'v6.0')
Drafts AutoSave 1.1 /home/dartsnut/domains/dartsnutz.net/public_html/forum/inc/plugins/MyFacebookConnect/class_facebook.php(165): Facebook\Facebook->get('/me?fields=id,n...')
ACP warning /home/dartsnut/domains/dartsnutz.net/public_html/forum/myfbconnect.php(66): MyFacebook->get_user()
Issues setting up Flyover {main}</trace>
</report>
Shade 23 Jul
#9
@nixer55 this is a different issue from OP's one. It has been already reported with the new 1.8.23 version, and I will investigate ASAP.
nixer55 24 Jul Edited
#10
Thanks Shade. Users can still register / login, but still throwing bug reports. All code 200, line 137, - or code 0, line 244. Here's a fresh code 0. Apologies, don't seem to be able to attach via your attachbox. User error I'm sure - lol:

<?xml version="1.0" encoding="UTF-8"?>
<report name="MyFacebook Connect" version="3.5">
        <id>696</id>
        <dateline>1595575116</dateline>
        <code>0</code>
        <file>/home/dartsnut/domains/dartsnutz.net/public_html/forum/myfbconnect/src/Facebook/Helpers/FacebookRedirectLoginHelper.php</file>
        <line>244</line>
        <message>Cross-site request forgery validation failed. Required param "state" missing from persistent data.</message>
        <trace> /home/dartsnut/domains/dartsnutz.net/public_html/forum/myfbconnect/src/Facebook/Helpers/FacebookRedirectLoginHelper.php(221): Facebook\Helpers\FacebookRedirectLoginHelper->validateCsrf()
#1 /home/dartsnut/domains/dartsnutz.net/public_html/forum/inc/plugins/MyFacebookConnect/class_facebook.php(128): Facebook\Helpers\FacebookRedirectLoginHelper->getAccessToken('https://www.dar...')
#2 /home/dartsnut/domains/dartsnutz.net/public_html/forum/myfbconnect.php(63): MyFacebook->save_token()
#3 {main}</trace>
</report>