Click anywhere to close this dialog

Farewell

Great is the art of beginning, but greater is the art of ending
Henry Wadsworth Longfellow

I announce that I cease all development and activity in the programming universe indefinitely. My career has reached the turning point I was not expecting for at least another year, leaving me highly off guard and without laid-out plans for this hobby's continuity. I have begun a 5-year residency program in Neurosurgery which is clearly not compatible, time-wise, with programming.

I gave in all my passion for developing, and you gave me back your loyalty and trust, even when I did not deserve that much. Now it is the time for payback. I release all my present and past work as Open Source software, in the hope some talented developer will continue maintaining and expanding my vision of a modern, sleek forum software. The intrinsic flexibility of MyBB is the true hidden gem of an otherwise outdated codebase; I do hope the project can continue and be updated complying to the latest coding standards.

I hereby thank Euan, kawaii, andrewjs18, Ben, Matt, Omar G., effone, Eric J., Devilshakerz, Wildcard, JordanMussi and all the other team members I have had the opportunity to work with when I was a MyBB team member. I thank Tomm M, my mentor, who inspired me to pick up coding with his piece-of-art plugins. And finally, I thank all of you MyBBoost subscribers who have helped me getting through my toughest university years economically.

Yours sincerely, Filippo

jQuery.Deferred exception: this.atwho

27 Dec 2019 Edited
#1
This issue is marked as solved
Probably a bug. MyBB version 1.8.21 & PHP version 7.3.7

Getting this from the console:
jQuery.Deferred exception: this.atwho is not a function init/<@https://mydomainname.tdl/forum/jscripts/util/rules.js:24:9
[email protected]://mydomainname.tdl/forum/jscripts/jquery.js?ver=1813:2:2573
[email protected]://mydomainname.tdl/forum/jscripts/util/rules.js:23:5
@https://mydomainname.tdl/forum/newthread.php?fid=3:688:20
[email protected]://mydomainname.tdl/forum/jscripts/jquery.js?ver=1813:2:29375
a/</c<@https://mydomainname.tdl/forum/jscripts/jquery.js?ver=1813:2:29677
undefined jquery.js:2:30930
TypeError: this.atwho is not a function rules.js:24:9
    init https://mydomainname.tdl/forum/jscripts/util/rules.js:24
    each jQuery
    init https://mydomainname.tdl/forum/jscripts/util/rules.js:23
    <anoniem> https://mydomainname.tdl/forum/newthread.php?fid=3:688
    jQuery 2
        l
        c

For some reason this is fixed now after installing all your premium plugins; deactivate QuickReferences and activate it again. I'm not sure if it's just me or if this will work for anyone following those steps.
Hüseyin Filiz 22 May 2020
#2
https://prnt.sc/slog8w

Same problem. I see this error too. I am using SCEditor. The id has been corrected as "message". There is no problem in the quick reply. It doesn't just work on SCEditor.
Shade 22 May 2020
#3
Can you please provide your board URL so I can have a look? Thank you.
Hüseyin Filiz 22 May 2020
#4
https://www.dedirten.com

if you need;
test
123456

I hope the forum language will not be a problem.
Shade 22 May 2020
#5
I suggest you to disable QuickReferences as it is incompatible with the new jQuery update over SCEditor. Unfortunately I have no time at the moment to fix it.
Hüseyin Filiz 22 May 2020 Edited
#6
can i use it with a quick reply? Mean, Is it a problem to use with quick reply? Thank u
Shade 22 May 2020
#7
QuickReferences is loaded in quick replies, however it is hard loaded also for standard replies. You will need to edit the plugin's code in order to load it only in quick replies rather than standard ones; I do not have time to show it to you atm though, sorry.
Hüseyin Filiz likes this post