30 May #1

Fatal error on plugin page

Ultimate subscriber
I get below error on admin CP ---> Plugins

Not able to see any plugins. On my 'Test' forum

Fatal error: Uncaught exception 'Exception' with message 'BankPipe requires PHP version 7.1 or higher.' in /home1/xxxxxx/public_html/Test/bankpipe/autoload.php:4 Stack trace: /home1/xxxxxx/public_html/Test/inc/plugins/bankpipe.php(22): include() #1 /home1/xxxxxx/public_html/Test/xx/modules/config/plugins.php(518): require_once('/home1/xxxxx...') #2 /home1/xxxxxx/public_html/Test/xx/index.php(766): require('/home1/xxxxxx...') #3 {main} thrown in /home1/xxxxxx/public_html/Test/bankpipe/autoload.php on line 4

Please help.
  • 1
  • 2
Shade 30 May
#2
As the message says, BankPipe requires PHP version 7.1 or higher.
Dr.Jeet 30 May
#3
After above error messgae, My hoster installed free SSL certificate as you guide and after that my subdomain on which I installed bankpipe show blank. Is it possible?
Shade 30 May
#4
Did you install PHP 7.1 or newer? That's what the error message said. SSL doesn't matter.
Dr.Jeet 30 May Edited
#5
Ya..installed. after installing my subdomain page become blank

I can not able to open http://www.xxx.com/Test but I can manage http://www.xxx.com/Test/admin/index.php
Shade 30 May
#6
Check out your error.log file, and send it privately. Also check on the minimum requirements to ensure you are not missing something.
Dr.Jeet 30 May
#7
error log of 28.5.2020....No recent error log.
Shade 30 May
#8
I will need your board url, and possibly a temporary server access as with this few info I can't really help further.
Dr.Jeet 30 May
#9
One error in errolog seen multiple time at different time interval in main domain directory.

Stack trace:
{main}
thrown in /home1/xxxxxx/public_html/xthreads_attach.php on line 49
[30-May-2020 1100 UTC] PHP Fatal error: Uncaught Error: Call to undefined function set_magic_quotes_runtime() in /home1/xxxxxx/public_html/xthreads_attach.php:49

Last seen at [30-May-2020 1444 UTC] PHP Fatal error:

Is it due to Upgradation of PHP version from 5.8.60 to 7.3 on mybb1866?
Shade 30 May
#10
It is, and it's an issue with XThreads, not BankPipe.