4 Aug #1

Uncaught TypeError: this.atwho is not a function

Ultimate subscriber
Uncaught TypeError: this.atwho is not a function
at HTMLBodyElement.<anonymous> (rules.js:24)
at Function.each (jquery.js?ver=1821:2)
at Object.init (rules.js:23)
at HTMLDocument.<anonymous> (newthread.php?fid=12:488)
at l (jquery.js?ver=1821:2)
at c (jquery.js?ver=1821:2)

This also affects scrolling on some pages like viewing new posts, posting a thread, etc.

When I disable this plugin , it is working again. What could this be?
Shade 4 Aug
#2
Might be an incompatibility with jQuery 3 yet again. Will check it out on monday, i am currently away from home.
day-day 4 Aug
#3
Might be an incompatibility with jQuery 3 yet again. Will check it out on monday, i am currently away from home.
Shade (4 Aug)
Thanks boss man!
Shade 4 Aug
#4
Nope, couldn't find any issues on a stock MyBB 1.8.21 version. So this might be an incompatibility with another plugin. Are you using other plugins which use at.js?
day-day 6 Sep
#5
This is also an issue I have. It works in quick reply, but not full editor (Creating new threads, full editor reply, etc)
jquery.js?ver=1821:2 Uncaught TypeError: this.atwho is not a function
    at HTMLBodyElement.<anonymous> (rules.js:24)
    at Function.each (jquery.js?ver=1821:2)
    at Object.init (rules.js:23)
    at HTMLDocument.<anonymous> (newthread.php?fid=2&processed=1:959)
    at l (jquery.js?ver=1821:2)
    at c (jquery.js?ver=1821:2)
Shade 6 Sep
#6
That’s QuickReferences. Likely the same incompatibility with JQ 3.
day-day 6 Sep
#7
That’s QuickReferences. Likely the same incompatibility with JQ 3.
Shade (6 Sep)
Correct. Are there any guides I should follow?
Shade 6 Sep
#8
Ops sorry I thought you posted in the Drafts Autosave thread. Not atm sorry.
Shade 15 Sep Edited
#9
I did some tests today and it seems it's working with jQuery 3.
- which browser are you using?
- can you share your board URL?

Thanks.