Flyover 2.4

26 Oct 2015 Edited
#1
Flyover is a plugin which lets your users register and login with over 20 different social networks and providers. It authenticates users loading just the necessary files, avoiding unuseful stuff and being as much neat as possible: it acts as a mediator between your board and external sites offering login capabilities.

I wanted to endorse this as a valuable plugin. At HF we decided to try social logins (FB, Google, Discord, and Twitter) just to gauge how well it would do. I really didn't want to spend a huge time on development and saw that this Premium (paid) plugin existed. It wasn't too expensive to get the MyBBoost Ultimate package and he has a reasonable amount of very good plugins.

Flyover was worth it all by itself because upon install our registration increased 30-50%. Yeah, by that much. I was shocked but those are true numbers. Apparently having a super easy way to register an account even though it links to your Google or Twitter account is what people want.

Technically this is a very good plugin and well-written. We made some custom alteration for visual but that was about it. Great plugin and I fully endorse it to all forum owners.
labrocca, hackforums.net owner
Downloaded FB/TW/G+/Steam from this package. Greaaat plugin, yet again, Shade. It's much more simple and straight forward compared to using the free versions, and I like the hybrid auth. Good stuff. I was reluctant to replace the free versions you made, but this is by far superior.
Tecca
This looks really good (and after testing it by registering for your forums it looks extremely good).
GXD3S

MyBBoost runs on Flyover, despite the interface is different, so you can register and try it on this site.



Compatible providers


Flyover is currently capable of full integration with BitBucket, Discord, Disqus, Dribbble, Facebook, Foursquare, GitHub, GitLab, Google, Instagram, LinkedIn, Mailru, Odnoklassniki, Spotify, StackExchange, Steam, Tumblr, TwitchTV, Twitter, Vkontakte, WeChat, WindowsLive (Microsoft), WordPress, Yahoo and Yandex.

Minimum requirements


cURL
PHP 7.1
MyBB 1.6 or 1.8, all minor versions included. MyBB 1.6 should be theoretically supported, but no support is given for this version
PluginLibrary

To install and configure Flyover, read Flyover documentation


Features


Powered by HybridAuth


Flyover relies on an open source project, HybridAuth, to communicate with external sites. The current version is powered by HybridAuth 3.3. HybridAuth serves as a secure and powerful communication layer between your board and each providers' website. Most if not all providers use OAuth 2.0 to authenticate users.

Hashed IDs


In order to ensure the highest level of privacy, users identifiers coming from every providers are hashed. You don't need to worry in case someone steals a database dump, your users are always safe and no one gets to know the user's social identity (unless they have synchronized easily identifiable data).

PM on registration


You can specify and fully customize a private message which will be delivered to the user upon registering. Several customization options are available.

Register without a password


Flyover is capable of registering users without the need for them to specify a password. This is available as an option, and it's disabled by default.

Multiple accounts


Your users can link multiple accounts to the same provider, and choose to login with whatever account they want.

High customization


Several customizations are available to enhance and personalize your experience with Flyover. Synchronization options with up to 10 data points collected during every login, while post-registration usergroup and full templates and stylesheets support are included. You can always specify provider-specific settings that will override the general configuration, including custom profile fields.

Other customizations will be introduced throughout free and flawless updates.

Updates always safe and with backwards compatibility


An updater is provided within the package which ensures that every update, whether you are jumping from the oldest version of the plugin to the latest, is always safe for your users and your database. You won't lose any data and new features will be available with one single click of a button, needed to run the upgrade script. Also, updates to existing features will always have backwards compatibility so you will not need to worry about missed templates updates or other styling customizations you've made to Flyover.

Got a question/issue?


If you encounter issues configuring providers or setting up Flyover, feel free to open a support thread here on MyBBoost.

What's next?


Follow Flyover development for updates and bug fixes.

Latest update: 5 January 2020


Availability


An Advanced or Ultimate subscription is required to download Flyover (click here to subscribe). Alternatively, you can perform a single purchase by adding the item to your cart and checkout at a later date. You can purchase using PayPal or several cryptocurrencies. Every successful payment lasts forever and may be refunded within 30 days if you are not satisfied.

Before purchasing or subscribing, read the End-User License Agreement (EULA).
Filename Size Downloads
Flyover 2.4.zip
159 KB 5
SrMorte, , MagnumPL And 2 others like this post
Shade 26 Oct 2015 Edited
#2

Previews


Take a look at Flyover's awesomeness with some fresh screenshots of it running on a live board!

[Image: UWxuw5l.png]
[Image: kpYwkat.png]
[Image: lmpWxGr.png]
[Image: 1N6NVii.png]
Enes Palit likes this post
Shade 1 Oct 2017 Edited
#3

Flyover 1.3 is out


This is a bugfix and feature release. It adds 3 new templates and alters all the existing ones.

Changed API endpoint


I have managed to introduce a new API endpoint for Flyover to simplify it and avoid exposure to the inc/plugins folder. The new API endpoint is managed through /flyover.php file. You MUST change all of your provider applications with the new API endpoint URI to ensure your users can continue to log in with them. Otherwise, they will be presented an error page most of the time with a "redirect URI must match the one registered into the application"-like error.

You can find the new endpoint URI in every provider's settings page.

Custom and required profile fields


Although they were sneakily introduced in 1.2, now custom profile fields and required ones at registration are supported officially; your users can now register through a social network while still being required to fill some fields before doing so.

Migrator from other plugins


You can now migrate from other well-known plugins offering login with social network capabilities within Flyover's module. A migration section is added for your convenience; the currently supported plugins are:

Multiple accounts


Ever wondered to log into multiple accounts with one social network? Flyover now lets you link your social network account with multiple MyBB accounts and lets you choose one upon logging in with ease.

[Image: aZV3xBP.png]

Discord integration


Discord has joined the big family of supported providers. It has been tested successfully and it's ready to be deployed to your website.

New data points


2 new data points are available: website and identifier. You can now set up custom profile fields to accomodate the user's identifier, while the website is synced with MyBB's user website field. The whole engine behind custom profile fields and data points has been revamped and it will be far more easy to create new ones in the future.

Minor bugfixes


Thanks to your usage and reports, I have fixed all minor bugs you've been spotting through these awesome 2 years. The complete list of fixed issues will be updated in the next couple of days.

To update your running Flyover copy:
  • perform a complete backup of both your files and your database;
  • download a new copy of Flyover from the first post. You can download the core package without downloading providers, but it's recommended to select your currently installed providers to perform a clean update, especially if you come from versions prior to 1.2 of 4 August 2017 in which I released an update to HybridAuth;
  • upload the new files. When you are done uploading, load a page in your admin control panel. You will be asked to run an upgrade script;
  • enjoy!

Please report any errors you may find when using the new version and I will be glad to assist you into fixing them as soon as possibile.
Eldenroot likes this post
Shade 3 May 2018 Edited
#4

Flyover 1.4 is out


This is a bugfix release. Thanks to @Jack Batch I have found and fixed some critical issues affecting some environments. In order to clean up the versions available due to some hotfixes released in the past months (and some issues with my git environment), I have decided to set a new minor release.

To update, simply replace the old files and run the upgrade script to update the version number.
Shade 9 May 2018
#5

Flyover 1.5 is out


This is a bugfix and security release. It is highly recommended to upgrade as soon as possible. It fixes:
  • 3 reported issues in servers with MySQL's Strict Mode enabled;
  • Facebook's deprecated user permissions;
  • a medium risk security vulnerability which as part of a responsible disclosure won't be explained to the general public. If you are a subscriber and want to know more about this issue, please PM me.

Special thanks to @Quinn Humphreys and @Jack Batch who helped me spotting them.

To upgrade, simply overwrite the old files with the new ones and run the upgrade script. As always, if you encounter any issue please report them either here or in a new thread, thank you.
Shade 2 Apr 2019
#6

PUBLIC ADDRESS LOUDSPEAKER Flyover 2.0 is out


Flyover 2.0 is out. This version features a code rewrite from the ground up and has been tested thoroughly for more than 1 month before being officially released.

FIRE Library update


HybridAuth has been updated to version 3.0 RC9, the latest available, with performance and error management improvements. This is a giant leap as it marks complete independence from every providers' own SDK. Some providers have been added and some have been discontinued. Continue reading to know more.

WHITE HEAVY CHECK MARK Custom scopes


Every provider can now be tweaked individually with custom scopes. You can add or remove scopes intelligently depending on what your application needs to retrieve.

BLOSSOM New ACP panel


The ACP panel overview has been revamped with new and more intuitive graphics. It now sports an users usage statistic and a faster access to tokens as well.

PENCIL New redirect URI


The infamous redirect URI has changed towards a simpler, standardized structure. You will need to change the redirect URI of every provider's application you are currently using right after updating Flyover in the control panel.

WARNING SIGN Refer to Flyover documentation in order to build and use the new redirect URI.

Other notable changes


The following list of new features have been added:
- new providers: GitLab, Mailru, Odnoklassniki, Spotify, WeChat, Yandex;
- new data point for synchronization: language;
- Suggestion: Disabling mybb login/registration in 1.6.

Critical changes


The following list of critical changes have been applied:
- WARNING SIGN minimum requirement is now PHP 7.1;
- WARNING SIGN dropped support for accounts without an email: from 2.0, users are required to specify an email. The emailless and passwordless option has been renamed Passwordless mode;
- WARNING SIGN some providers have been discontinued: AOL, BeatsMusic, Deezer, Dropbox, LastFM, PayPal, Pinterest, SoundCloud, Vimeo, 500px;
- WARNING SIGN Microsoft has been renamed WindowsLive;
- WARNING SIGN popup mode has been discontinued due to chronic instability.

It is highly recommended to try version 2.0 on a test board before deploying it live, which is encouraged anyway. Export your tokens and perform a database dump before upgrading Flyover.

Upgrading to version 2.0


The upgrade process is straightforward:
KEYCAP 1 delete /inc/plugins/Flyover
KEYCAP 2 upload the new version maintaining the same folder structure as in the release package
KEYCAP 3 run the upgrade script when asked in the ACP
KEYCAP 4 rebuild Flyover's cache from Configuration > Flyover > Rebuild cache.

Templates and stylesheets have been changed accordingly to reflect code changes. Being a major release, lots of edits have to be made. For your convenience, a diff comparison is attached to this post in standardized git format.
Filename Size Downloads
22.25 KB 3
GXD3S likes this post
Shade 1 Aug 2019
#7

PUBLIC ADDRESS LOUDSPEAKER Flyover 2.1 is out


This is a security and bugfix release.

LOCK addressed medium risk vulnerability affecting Discord. Reported by @Omniscient. If you want a deeper insight on this vulnerability, PM me
BUG fixed fast registration which was breaking the plugin's basic functionalities if the option was turned on

It is highly recommended to upgrade to version 2.1 as soon as possible.

This release changes 1 template. A patch file is available below; you can view the differences between versions 2.0 and 2.1 by using an online tool, or your preferred git manager.
Filename Size Downloads
685 bytes 6
ShockPuppet likes this post
Shade 5 Jan
#8

PUBLIC ADDRESS LOUDSPEAKER Flyover 2.2 is out


This is a bugfix and feature release. Thanks to all reporters and users who have contributed.

FIRE HybridAuth update to 3.1.1
SQUARED NEW Suggestion: Disabling mybb login/registration in 1.6. Force operational status has been extended to cover both logging in and registering
SQUARED NEW use provider-specific custom fields to avoid overwriting profile data. Requested in Facebook profile link/url by @Enes Palit
SQUARED NEW Feature request: disable unlinking from provider
SQUARED NEW profile URL and email as new custom profile fields. Requested in Facebook profile link/url by @Enes Palit
SQUARED NEW Amazon provider. Requested in Amazon Request by @Omniscient
BUG synchronization does not occur upon registering. Reported by @Enes Palit in Facebook profile link/url
BUG synchronization options do not save upon registering
BUG "language" field is missing from the language files. Reported by @Enes Palit in Facebook profile link/url

Notable changes


The Force operational status setting has been renamed to Operational status and switched from a simple on/off button to a selectbox with several options. You can now force logging in, registering or both through social networks rather than relying on the standard login/register forms.

Upgrading to version 2.2


KEYCAP 1 delete the /flyover folder
KEYCAP 2 upload and overwrite the old files
KEYCAP 3 run the upgrade script from the Admin Control Panel when asked

This release does not change templates, but changes the only stylesheet (located in inc/plugins/Flyover/stylesheets) with minor changes to accomodate the new Amazon provider.
metonator and Enes Palit like this post
Shade 16 Apr
#9

PUBLIC ADDRESS LOUDSPEAKER Flyover 2.3 is out


This is a bugfix and framework update release.

FIRE HybridAuth update to 3.3, with the most notable change occurring to Facebook's Graph API switching from v2.12 to v6.0. Version 2.12 will be deprecated starting from 5 May 2020
BUG fixed [BUG] Facebook registering results in email = 1

Upgrading to version 2.3


KEYCAP 1 delete the /flyover folder
KEYCAP 2 upload and overwrite the old files
KEYCAP 3 run the upgrade script from the Admin Control Panel when asked

This release changes 1 template, flyover_register_settings_setting. If you have customized such template, update it accordingly.
Shade 16 Oct
#10

PUBLIC ADDRESS LOUDSPEAKER Flyover 2.4 is out


This is a bugfix release.

BUG fixed Switching on Force Login causing inability to log into admin CP

Upgrading to version 2.4


KEYCAP 1 upload and overwrite the old files