Click anywhere to close this dialog


Great is the art of beginning, but greater is the art of ending
Henry Wadsworth Longfellow

I announce that I cease all development and activity in the programming universe indefinitely. My career has reached the turning point I was not expecting for at least another year, leaving me highly off guard and without laid-out plans for this hobby's continuity. I have begun a 5-year residency program in Neurosurgery which is clearly not compatible, time-wise, with programming.

I gave in all my passion for developing, and you gave me back your loyalty and trust, even when I did not deserve that much. Now it is the time for payback. I release all my present and past work as Open Source software, in the hope some talented developer will continue maintaining and expanding my vision of a modern, sleek forum software. The intrinsic flexibility of MyBB is the true hidden gem of an otherwise outdated codebase; I do hope the project can continue and be updated complying to the latest coding standards.

I hereby thank Euan, kawaii, andrewjs18, Ben, Matt, Omar G., effone, Eric J., Devilshakerz, Wildcard, JordanMussi and all the other team members I have had the opportunity to work with when I was a MyBB team member. I thank Tomm M, my mentor, who inspired me to pick up coding with his piece-of-art plugins. And finally, I thank all of you MyBBoost subscribers who have helped me getting through my toughest university years economically.

Yours sincerely, Filippo

QuickReferences.load_configuration is not a function

9 Aug 2016 Edited
This issue is marked as solved
Got this error for the latest update (1.1)

rineditor.js:1 Uncaught TypeError: QuickReferences.load_configuration is not a function
The Quick References won't work because of this error, I assume.
Shade 9 Aug 2016
Registered and tried on your board, and it works fine for me. Can you be more specific, like giving a step by step guide to reproduce the issue? Thank you.
kopa 9 Aug 2016
Well, the error occurs whenever I view a page with the Rin Editor (new topic, new reply, showthread). I type #, followed by any character and nothing shows up. So I inspect element to see what's up, and it gave me the error. [Image: b4fptxu.png]
Shade 9 Aug 2016
What browser are you using? As I said before, it works for me.
kopa 9 Aug 2016
I'm using Google Chrome.
Shade 9 Aug 2016
It might be that you have the old version saved in your browser's cache. Void your cache and retry. From 1.2, a versioning system for JavaScripts will be added so new versions will be loaded automatically.
kopa 15 Aug 2016
How do I void cache? By clearing them. If so, I did and it didn't work :(
Shade 15 Aug 2016
If you are using any CDN (eg.: CloudFlare), clear the cache from it too, otherwise the new file won't be loaded. Can you inspect your site using your browser's console, search for the file /jscripts/util/rules.js and copy its code here? Thank you.
kopa 15 Aug 2016
Here's the code:
<script type="text/javascript" src="jscripts/util/rules.js"></script>
Shade 15 Aug 2016
I meant the actual source code of the file. Anyway, glad you got it sorted! As I said in my previous replies, the next version will not need anything like a cache wipeout since the JavaScripts will have a versioning query string :)