26 Nov 2019 Edited #1

Problem with notification emails

Ultimate subscriber
I am getting some strange email notifications when a members purchases a subscription. I also did not even receive 1 with the last transaction...

Sample email received:

Dear merchant,
jpaz has purchased the following list of items:

    Site Supporter

This transaction was 75&Suggestion - Migration;, of which 2.48&Suggestion - Migration; were retained in processing fees. A net revenue of 72.52&Suggestion - Migration; has been credited to [email protected]

Best regards,
7173MUSTANGS.com
RocketFoot 26 Nov 2019 Edited
#2
Here is another example that just came in...

Dear merchant,
[url=https://www.7173mustangs.com/user-stanglover]Stanglover[/url] has purchased the following list of items:

[list][*]Site Supporter[/list]

This transaction was [b]25&Suggestion - Migration;[/b], of which 1.40&Suggestion - Migration; were retained in processing fees. A net revenue of [b]23.6&Suggestion - Migration;[/b] has been credited to [email protected]

Best regards,
7173MUSTANGS.com
Shade 26 Nov 2019
#3
The weird stuff is simply the currency which is not properly formatted into the corresponding HTML entity. I'm working on it.
RocketFoot 7 Jan Edited
#4
Just wondering if this has been addressed yet? I am still receiving weird text in my notification emails...

Dear merchant,
[url=https://www.7173mustangs.com/user-jd79]JD79[/url] has purchased the following list of items:

[list][*]Raffle Ticket[/list]

This transaction was [b]3&Suggestion - Migration;[/b], of which 0.43&Suggestion - Migration; were retained in processing fees. A net revenue of [b]2.57&Suggestion - Migration;[/b] has been credited to [email protected]

Best regards,
7173MUSTANGS.com
Shade 7 Jan
#5
You can ignore it for now. It's just HTML entities of currencies (in your case, I desume $). This may be as well an issue with MyBB's core and how it handles entities in emails. Not top priority.