9 Apr #1

Coinbase webhook test failure

Ultimate subscriber
Remote server returned an HTTP 503
Do I have to whitelist some coinbase IP's?
  • 1
  • 2
Shade 9 Apr
#2
If you server is restricting access to Coinbase, yes, you will need to whitelist their IPs. Unfortunately I do not know how to retrieve those IPs I am afraid.
Kalju 9 Apr
#3
Cloudflare blocked it with a jsrequest, so I whitelisted coinbase, works now.
Kalju 10 Apr Edited
#4
Coinbase payments are verified, but account doesn't get upgraded automatically, even after waiting for hours.
Only sent tests work.
Shade 10 Apr
#5
Can you make a screenshot of your subscription settings please?
Kalju 11 Apr
#6
PayPal accounts get upgraded fine, just Coinbase keeps displaying pending.
Shade 11 Apr
#7
Are you sure you have whitelisted Coinbase's servers properly? Coinbase payments are verified through webhooks. Check your page hits logs.

Also, have you disabled ONLY_FULL_GROUP_BY?
Kalju 11 Apr
#8
I whitelisted their ASN and I have removed that from SQL_MODE. Do you know if they have more than one ASN?
Shade 11 Apr
#9
Honestly, I don't know. My first guess would be looking in your page hit logs and whitelist each IP associated with coinbase.com POST visits.
Kalju 12 Apr Edited
#10
It works now, I guess the previous payments were sent with ONLY_FULL_GROUP_BY enabled.