Click anywhere to close this dialog


Great is the art of beginning, but greater is the art of ending
Henry Wadsworth Longfellow

I announce that I cease all development and activity in the programming universe indefinitely. My career has reached the turning point I was not expecting for at least another year, leaving me highly off guard and without laid-out plans for this hobby's continuity. I have begun a 5-year residency program in Neurosurgery which is clearly not compatible, time-wise, with programming.

I gave in all my passion for developing, and you gave me back your loyalty and trust, even when I did not deserve that much. Now it is the time for payback. I release all my present and past work as Open Source software, in the hope some talented developer will continue maintaining and expanding my vision of a modern, sleek forum software. The intrinsic flexibility of MyBB is the true hidden gem of an otherwise outdated codebase; I do hope the project can continue and be updated complying to the latest coding standards.

I hereby thank Euan, kawaii, andrewjs18, Ben, Matt, Omar G., effone, Eric J., Devilshakerz, Wildcard, JordanMussi and all the other team members I have had the opportunity to work with when I was a MyBB team member. I thank Tomm M, my mentor, who inspired me to pick up coding with his piece-of-art plugins. And finally, I thank all of you MyBBoost subscribers who have helped me getting through my toughest university years economically.

Yours sincerely, Filippo

Can't reset passwords due to fatal PHP error

7 Jan 2020 Edited
This issue is marked as solved

You are viewing page #2

Show original post
RocketFoot 2 Apr 2020
It did add the modpack edits to the file but the password reset failed to work again. I have it uninstalled for now.
Shade 2 Apr 2020
If you installed them manually, you have to remove some trailing slashes which are embedded in the plugin’s automatic functions. That’s why it fails to deliver most probably. If you hand me a temp server access, I can see what’s wrong.
RocketFoot 2 Apr 2020
PM sent
Shade 2 Apr 2020
Solved in the last update. Thank you for your report!
RocketFoot 2 Apr 2020
Issue seems to be resolved with 4.0.1 update! Thanks Shade! Love the new look here on the website too!
RocketFoot 3 Apr 2020
Shade, I did notice one weird thing after the update...when I click delete all alerts from my alert modal, the screen goes to a board message screen with this comment:

An invalid search was specified. Please go back and try again.

It usually went back to the index page after deleting all alerts. Is this normal?
Shade 3 Apr 2020
The update just includes the change for password reset, so it's very unlikely the culprit for your issue. Besides, deleting all alerts from the modal is not supported by MyAlerts out of the box, so I guess you have edited the code somehow.