Welcome

High quality MyBB plugins at your disposal

Hi, I am a passionate developer with modernity and simplicity in mind. MyBBoost is my mansion where you can download my plugins and themes, other than receiving support for them. Several free plugins are available as well as premium ones, all compatible with the latest MyBB releases. You can purchase and download items singularly or purchase a lifetime subscription including a combination of premium plugins and:

  • Priority support
  • Future plugins access
  • Total refund if not satisfied 1
1 Terms and conditions apply. For more informations, read the EULA.

Avatars not displayed properly if using default avatars

Eldenroot Regular user 10 Sep 2016 Edited
#1
Another minor bug - there is no avatar shown in a popup dropdown menu when the author of the thread uses a default avatar. Just a blank image.

[Image: GEmG5K4.png]
Shade Administrator 25 Sep 2016 Edited
#2
This behavior depends on how the default avatar plugin you are using works. Ideally it should add a default avatar upon registration and register it to the database, which would work with QuickReferences. However, and it might be your case, if the plugin is adding default avatars when requested QuickReferences has no way to know if the user has a default avatar or not.

I can fix this partially by ensuring an avatar is always displayed, but beware that the default image will be not using external plugins (it will be a simple image, located in images/default_avatar.png which if you don't have you will need to upload).
Eldenroot Regular user 3 Oct 2016
#3
I dont use any plugin. Just default MyBB 1.8.x feature - it has an own picture for users without avatar uploaded
Shade Administrator 3 Oct 2016
#4
I didn't know MyBB 1.8 has a default avatar option built in. I will investigate.
Brenda Advanced 3 Oct 2016
#5
Yea it has a default avatar. /default_avatar.png.

However I use dvz random avatars, works really well.
[Image: k5XKGab.png]
Eldenroot Regular user 8 Oct 2016
#6
Yes, DVZ random avatars works fine - it replaces default avatar by a random one.

However when a user use only default avatar -> no avatar is shown in a popup window.

Shade - MyBB 1.8 applies to all users without their own avatar the default one (settings is located here: ACP->Profile options->Default avatar

[Image: S85FQ0W.png]

There is a mod (I havent tested it yet) - maybe it can fix the issue:
https://community.mybb.com/mods.php?action=view&pid=375
Shade Administrator 8 Oct 2016
#7
Nope, that will not fix the issue. However I have fixed it in 1.2 and I will push the update as soon as possible. The only thing I am worried about is Unicode characters are not displayed properly, which would imply adding an utterly heavy external library to the package. I am actively looking for a better solution.
  • 3 participants